https://pulumi.com logo
#kubernetes
Title
# kubernetes
s

some-continent-7311

09/29/2022, 7:40 AM
After upgrading
@pulumi/pulumi
and
@pulumi/kubernetes
to
^3.0.0
and running
pulumi up
I get this warning:
Copy code
W0929 13:38:59.750875   65229 gcp.go:119] WARNING: the gcp auth plugin is deprecated in v1.22+, unavailable in v1.26+; use gcloud instead.
    To learn more, consult <https://cloud.google.com/blog/products/containers-kubernetes/kubectl-auth-changes-in-gke>
What should I do exactly to get rid of the warning?
I followed the instructions outlined on this page: https://cloud.google.com/blog/products/containers-kubernetes/kubectl-auth-changes-in-gke but it does not seem to help.
g

gorgeous-egg-16927

09/29/2022, 3:55 PM
Have you updated your kubeconfig? Here’s an example where I fixed this issue recently in our CI test cluster configuration.
s

some-continent-7311

09/30/2022, 12:08 PM
That’s exactly what I needed. Thank you
🎉 1
Btw, I found this page which I believe was the tutorial that we used to create the cluster: https://www.pulumi.com/registry/packages/kubernetes/how-to-guides/gke/
And this page is still using the old code in the
user:
section.
Maybe you guys want to update this page, too.
👍 1
4 Views