https://pulumi.com logo
#kubernetes
Title
# kubernetes
f

fast-dinner-32080

03/31/2020, 4:29 AM
I am running pulumi with the kubernetes provider manually set but I also manually updated my KUBECONFIG to a bad value. Now when I run it I get this warning "warning: configured Kubernetes cluster is unreachable: unable to load Kubernetes client configuration from kubeconfig file: invalid configuration: no configuration has been provided" Why does it care about my env variable and/or file if I am manually setting the provider and setting the kubeconfig. I have found a few times it tries to load the env var or file when I do not want it too so I am manually setting it too a bogus value to make sure it doesn't mess with my current local context.
g

gorgeous-egg-16927

03/31/2020, 3:31 PM
Config set on the first-class provider should override ambient config. Precedence is 1. First-class provider 2. pulumi config values 3. Ambient KUBECONFIG If that’s not the case for you, please file an issue on the pulumi-kubernetes repo
f

fast-dinner-32080

03/31/2020, 3:32 PM
Okay cool, i will do some testing and make sure this is working correctly.
👍 1
b

billowy-army-68599

03/31/2020, 3:53 PM
for me, I had missed setting the provider on one resource which meant it was reverting to the
KUBECONFIG
var
f

fast-dinner-32080

03/31/2020, 3:54 PM
Would be nice to disable the KUBECONFIG var since my shell does some automatic work to set this and allow me to quickly switch files. I only want pulumi to use config and fiest-class.
that way I know when I miss providing it
else it could cause some issues with modifying clusters that I did not mean too
We’ve also considered adding a stack configuration to disable ambient KUBECONFIG. It’s nice for users getting started, but can cause the problem you found.
Here’s a tracking issue for that: https://github.com/pulumi/pulumi/issues/3383
f

fast-dinner-32080

03/31/2020, 4:11 PM
Okay cool, I just commented on that issue.
setting the dummy value should fix it for now
12 Views