https://pulumi.com logo
#aws
Title
# aws
a

abundant-airplane-93796

05/07/2020, 5:55 PM
Just started running into errors that look like this:
Copy code
preparing urn:pulumi:sandbox::irisvr-infra::aws:s3/bucket:Bucket::prospect-releases's old property state: expected string or JSON map; got <nil>
g

gentle-diamond-70147

05/07/2020, 9:46 PM
I've not seen this error before. What steps did you do prior to hitting this?
a

abundant-airplane-93796

05/08/2020, 12:53 AM
hard to put my finger on - which is terrible I know. I had just upgraded the
@pulumi/aws
module to 2.3.0 from 2.2.0 -but I'm not convinced that's it. certainly rolling it back hasn't fixed anything
I was in the middle of reorganizing my repository - moving some resources around, but without renaming anything, and suddenly started hitting this error.
i've tried completely removing the s3 bucket in question from state and 'importing' it, but I get the same error
g

gentle-diamond-70147

05/08/2020, 1:14 AM
If you're able to reproduce this consistently, would you mind opening an issue at https://github.com/pulumi/pulumi/issues/new with the code that reproduces it?
a

abundant-airplane-93796

05/08/2020, 1:22 AM
yup - it's something about the current state of the bucket. with a fresh pure new project I can 'get' the bucket, but attempting to import it to take full control gives me the error again
g

gentle-diamond-70147

05/08/2020, 1:33 AM
Thanks