https://pulumi.com logo
#aws
Title
# aws
l

little-cartoon-10569

10/19/2020, 8:18 PM
I'm updating the security groups on an EC2 instance I've just created. I'm getting a panic in the Go SDK.
I've just noticed that the trace says v2.9.1-0, but I'm running 2.12.0. Maybe the CLI and SDK versions are out of sync?
This is quite frustrating. I'm sure most people don't suffer from it: many people must work with EC2 instance VPC security group IDs, but not many people have mentioned the problem. So I'm guessing there's another way to manage arrays of IDs so that this doesn't crash all the time?