https://pulumi.com logo
#getting-started
Title
# getting-started
a

adventurous-author-44528

03/26/2021, 1:29 PM
Hi. trying to use pulumi on a Macbook Pro M1,
pulumi up
returns:
Copy code
error: could not load plugin for kubernetes provider 'urn:pulumi:prod-bravo-excelproc::excel-processor::pulumi:providers:kubernetes::default_2_6_1': no resource plugin 'kubernetes-v2.6.1' found in the workspace or on your $PATH, install the plugin using `pulumi plugin install resource kubernetes v2.6.1`
runnig the suggested install command returns
Copy code
error: [resource plugin kubernetes-2.6.1] downloading from : 403 HTTP error fetching plugin from <https://get.pulumi.com/releases/plugins/pulumi-resource-kubernetes-v2.6.1-darwin-arm64.tar.gz>
any ideas ?
b

brave-planet-10645

03/26/2021, 1:34 PM
You ned to make sure you're using the right versions of the pulumi cli and the providers. The earliest version of the kubernetes provider that supports ARM64 (and therefore the M1 chip) is 2.8.3
c

cool-fireman-90027

03/26/2021, 1:34 PM
b

brave-planet-10645

03/26/2021, 1:35 PM
If you try to use any earlier version with the version of the Pulumi CLI that supports ARM64 then it returns a 403
c

cool-fireman-90027

03/26/2021, 1:37 PM
The last comment in this will help with troubleshooting: https://github.com/pulumi/pulumi/issues/4868
a

adventurous-author-44528

03/26/2021, 1:41 PM
it actually reported on first try:
Copy code
[resource plugin kubernetes-2.8.3] installing
Downloading plugin: 25.82 MiB / 25.82 MiB [=========================] 100.00% 8s
 
error: could not load plugin for kubernetes provider 'urn:pulumi:prod-bravo-excelproc::excel-processor::pulumi:providers:kubernetes::default_2_6_1': no resource plugin 'kubernetes-v2.6.1' found in the workspace or on your $PATH, install the plugin using `pulumi plugin install resource kubernetes v2.6.1`
make: *** [deploy-prod] Error 255
so it looks like it installed 2.8.3 but then wants 2.6.1 of the plugin. running `pulumi plugin install resource kubernetes v2.8.3`returns nothing and the plugin is not installed
forcing a reinstall prints out:
Copy code
[resource plugin kubernetes-2.8.3] installing
Downloading plugin: 0 B / 25.82 MiB [-------------------------------]   0.00% 0s
b

brave-planet-10645

03/26/2021, 1:44 PM
What do you see if you run
pulumi plugin ls
?
a

adventurous-author-44528

03/26/2021, 1:46 PM
actually this plugin is listed there:
Copy code
atli@Atlis-MacBook-Pro-2 pulumi % pulumi plugin ls
NAME        KIND      VERSION  SIZE   INSTALLED       LAST USED
kubernetes  resource  2.8.3    66 MB  38 minutes ago  38 minutes ago

TOTAL plugin cache size: 66 MB
but it always tryes to fetch the old one, will have a look at the package.json mentioned in the github comment
b

brave-planet-10645

03/26/2021, 1:49 PM
might be worth deleting the package-lock.json and the node_modules folder to be safe
and then running
npm i
a

adventurous-author-44528

03/26/2021, 1:51 PM
I am bit of a pulumi noob, is this a package.json for pulumi ? (my application is not a node app)
b

brave-planet-10645

03/26/2021, 1:53 PM
what language are you using?
a

adventurous-author-44528

03/26/2021, 1:53 PM
python
b

brave-planet-10645

03/26/2021, 1:54 PM
ok, then your requirements.txt
package.json would be for nodejs
a

adventurous-author-44528

03/26/2021, 1:55 PM
requirements.txt:
Copy code
pulumi-kubernetes==2.8.3
b

brave-planet-10645

03/26/2021, 1:56 PM
can you do
pulumi stack export > stack.json
- it's possible that it's in there too. Do you'll need to update that as well
So if you export the stack to stack.json then see if you can see
Copy code
pulumi:providers:aws::default_2_6_1
a

adventurous-author-44528

03/26/2021, 1:57 PM
yeah, that has
kubernetes::default_2_6_1
b

brave-planet-10645

03/26/2021, 1:59 PM
so where it says either 2_6_1 or 2.6.1 you'll have to change to the appropriate version
Then run
pulumi stack import --file stack.json
a

adventurous-author-44528

03/26/2021, 2:03 PM
ok. thanx we will try this
problem solved. thanx.
b

bitter-rain-31542

03/26/2021, 2:10 PM
We ended up deploying this with
pulumi-kubernetes==2.8.3
from an intel mac instead of messing around with a massive json file
1
b

brave-planet-10645

03/26/2021, 2:19 PM
Does that force it even if you already have a different version of the provider in the stack?
b

bitter-rain-31542

03/26/2021, 2:23 PM
I wiped my pulumi venv, reinstalled with 2.8.3 and made a no-diff
pulumi up
. That was enough to force it in the stack, even though the output didn’t indicate any changes. Now we can deploy from m1 macs
Perhaps a bit more opaque method of fixing this, but I never feel particularly brave editing hundreds of lines of json by hand 😅
b

broad-dog-22463

03/26/2021, 2:50 PM
FWIW, this issue only exists the first time we upgrade on arm64 😕
so you've done the right thing - do the upgrade on non-m1 machine and then you are able to use the arm64 machine
a

adventurous-author-44528

03/26/2021, 2:51 PM
Also maybe a better error handling would have been nice.
b

broad-dog-22463

03/26/2021, 2:52 PM
hey @adventurous-author-44528 - I'd love it if you could open an issue around that - we should make that better
👍 1
a

adventurous-author-44528

03/26/2021, 9:11 PM
b

broad-dog-22463

03/26/2021, 9:15 PM
Thank you!
3 Views