Hi all, trying out Pulumi for the first time. I'm ...
# getting-started
h
Hi all, trying out Pulumi for the first time. I'm getting a reproducible issue that I can't figure how to fix. I followed the GCP tutorial and created a bucket. Now, what I want to test is the
pulumi refresh
command. I manually deleted the bucket from GCP and tried to run
pulumi refresh
to see if it would notice the change. However, it hangs forever, and if I run it with
pulumi refresh --logtostderr -v=9
I see that it seems to infinitely encounter this
Copy code
I1109 12:44:31.269962   54836 eventsink.go:62] eventSink::Debug(<{%reset%}>Dismissed an error as retryable. Retry 404s for bu
cket creation - googleapi: Error 404: The specified bucket does not exist., notFound<{%reset%}>)
I know you can manually alter the state to tell it a resource has been deleted but that's not a long term solution for us.
b
So there's not a problem with the getting started tutorial, but there seems to be a problem when running a refresh after manually deleting a bucket?
h
Yes, the tutorial itself was perfectly fine, the error only occurred when I manually deleted the bucket in GCP
b
Would you mind creating an issue in the GCP repo: https://github.com/pulumi/pulumi-gcp that's going to be the fastest way to get this looked at
👍 1
h
Thanks, I've created an issue here https://github.com/pulumi/pulumi-gcp/issues/689
🙌 1