https://pulumi.com logo
#general
Title
# general
d

dazzling-area-7593

02/25/2020, 4:08 AM
Hi! I am having some issue deploying EKS. I initially tried deploying to us-east-1. It was able to deploy some resources but not the cluster (the cluster could not be provision for lack of capacity). So I changed the region and tried again. Doing this it tried to change some resources to the new region. It was able to successfully create the cluster resources and the cluster is up and running but it completed with error. Now the state has 2 resources (eksClusterInternetEgressRule and eksClusterSecurityGroup) that it tries to delete everytime I run a
pulumi up
but it fails everytime with a
No security group with ID "XXX"
error message. I am not able to modify my infrastructure because of those 2 resources. I tried removing the resources from the state by specifying the urn and it can’t find them either…
w

white-balloon-205

02/25/2020, 4:39 AM
I tried removing the resources from the state be specifying the urn
You may need to escape the urn with quotes to ensure your shell doesn’t handle
$
in the URN. If that still doesn’t work, you can
pulumi export
then remove the offending resources then
pulumi import
. As for the initial situation you end up in when switching regions, improving this is tracked in https://github.com/pulumi/pulumi-aws/issues/879 (and ultimately https://github.com/pulumi/pulumi-terraform-bridge/issues/14).
d

dazzling-area-7593

02/25/2020, 2:56 PM
Thanks @white-balloon-205 that was the issue, I didn’t see the
$
in the urn.