https://pulumi.com logo
#general
Title
# general
i

important-boots-43281

03/25/2020, 7:01 PM
Hi, I'm new to Pulumi, we're doing a test with a lambda function and API gateway. The deployment worked fine when everything was in one big file, but after we moved things into ComponentResources, we're getting an error
Error creating Lambda function: ResourceConflictException: Function already exist:
when we try to create the actual lambda function. The function is actually being created, but it seems like pulumi is trying to create it twice for some reason. The created function isn't destroyed by a pulumi destroy, so it doesn't ever seem to get registered with the state. Any ideas on what I'm doing wrong?
a

adorable-action-51248

03/26/2020, 7:50 AM
have something similar with cloudrun for some setups. (not all some though). i was able to work around it with appending
--refresh
.
pulumi up --refresh
not sure if it helps in your case ?
a

astonishing-gpu-37274

05/23/2020, 10:25 AM
I experienced exactly the same issue you're describing, made a protoype in one big file, extracted to components and when now trying to create a stack from scratch using the refactored code, I get the 409 error. Tried also going back to the old code and now it's not working
2 Views