https://pulumi.com logo
#announcements
Title
# announcements
g

gorgeous-egg-16927

09/02/2020, 5:18 PM
https://github.com/pulumi/pulumi-kubernetes/releases/tag/v2.5.1 is out now, and has several important changes: * Improved typing support for the Python SDK (see also https://www.pulumi.com/blog/announcing-python-tooling-improvements/) * Fixed a regression for NodeJS .get methods introduced in v2.5.0 * Switched Helm v3 support to use the native library rather than shelling out to the CLI (NodeJS and Python in this release; .NET and Go coming soon)
partypus 8bit 2
🙌 9
👍🏼 3
l

limited-rainbow-51650

09/16/2020, 9:44 AM
@gorgeous-egg-16927 for my information, if I use Helm v3, does this mean I no longer need the CLI installed to run Pulumi?
g

gorgeous-egg-16927

09/16/2020, 2:15 PM
Yes, that’s correct.
👏🏼 1
n

narrow-jackal-57645

09/18/2020, 2:30 AM
Is it also applicable for Helm v2?
g

gorgeous-egg-16927

09/18/2020, 3:13 PM
No, the v2 support hasn’t changed. However, you should be able to switch to the v3 API without disruption because the resources are automatically aliased and backward compatible.
👍 1
2 Views