https://pulumi.com logo
#announcements
Title
# announcements
b

broad-dog-22463

04/22/2021, 8:10 PM
Friends, we just released Pulumi v3.1.0 with an apology notice in our CHANGELOG. TL;DR, 2 features that we listed as breaking in the 3.0 upgrade didn't actually make it into the release ๐Ÿ˜• Therefore, we had to include them now as they were behaviours we depended upon I apologise for any problems this causes and we will make sure that this doesn't happen again! If you have any questions, then please let me know https://github.com/pulumi/pulumi/releases/tag/v3.1.0
๐Ÿ‘ 7
๐Ÿ‘ 3
๐Ÿบ 8
m

mammoth-electrician-64525

04/22/2021, 9:42 PM
Hi @broad-dog-22463, thank you. you for your hard work in keeping it working properly. A quick question: I updated my CLI using brew, updated my python packages using pip but I canโ€™t see the upgrade in the GitHub Actions Pulumi that uses Pulumi CLI also? (https://github.com/pulumi/actions/releases) can you check out that? Thank you in advance.
b

broad-dog-22463

04/22/2021, 9:45 PM
Hi @Marcelo, yes we will need to create a GitHub Actions release now that this is out there - I will get that taken care of for sure
๐Ÿ‘ 1
m

mammoth-electrician-64525

04/22/2021, 9:57 PM
Thanks, Iโ€™ll learn with your future commit to the next time, help the project submitting a PR ๐Ÿ˜„
b

broad-dog-22463

04/22/2021, 9:59 PM
oh if you are using the action-install-pulumi-cli then you will be getting the CLI upgrade for free very soon!
we just merged the version change PR on our docs site
so it'll happen automatically
๐Ÿ‘ 1
m

mammoth-electrician-64525

04/22/2021, 10:41 PM
yeah, Iโ€™m using but Iโ€™m not sure if my setup will receive the Pulumi 3.1.0 correctly, I guess that will be necessary change the version
pulumi/action-install-pulumi-cli@v1.0.3
Copy code
- name: Install Pulumi
  uses: pulumi/action-install-pulumi-cli@v1.0.2
      
- name: Install Pulumi Requirements
  run: make install
     
- name: Pulumi Up 
  uses: pulumi/actions@v3
  with:
     command: up
     stack-name: ORG/REPO/STACK
  env:
     PULUMI_ACCESS_TOKEN: ${{ secrets.PULUMI_ACCESS_TOKEN }}
     AWS_ACCESS_KEY_ID: ${{ secrets.AWS_ACCESS_KEY_ID }}
     AWS_SECRET_ACCESS_KEY: ${{ secrets.AWS_SECRET_ACCESS_KEY }}
     AWS_REGION: ${{ secrets.AWS_REGION }}
b

broad-dog-22463

04/22/2021, 11:04 PM
Action-install-Pulumi-cli will pick up latest as specified https://www.pulumi.com/latest-version unless you pin to a version :)
๐Ÿ‘ 1
m

mammoth-electrician-64525

04/22/2021, 11:19 PM
@broad-dog-22463 thanks for clarifying that piece, it is really nice improvement on the CLI side. It is so flexible because if I would like to use the latest automatically I can do or if I want to freeze the version to avoid surprises I can do it also. Thanks for that contribution is an incredible resource for our automation process.
๐Ÿ™ 1
g

glamorous-helmet-50600

04/23/2021, 8:40 AM
@broad-dog-22463 Pulumi 3.1.0 doesn't seem to be available through Chocolatey
b

broad-dog-22463

04/23/2021, 9:00 AM
Iโ€™ll check it out now - thanks @glamorous-helmet-50600
We have an automated job that submits the packages after release
g

glamorous-helmet-50600

04/23/2021, 9:07 AM
Seems to be waiting for Maintainer (status on chocolatey)
b

broad-dog-22463

04/23/2021, 9:10 AM
Yeah I see the issue now - will get it fixed up
p

purple-train-14007

05/11/2021, 9:27 PM
We forgive you โค๏ธ