Thread
#general
    w

    wonderful-motherboard-66151

    5 months ago
    I was wondering if somebody could help me out with creating some Azure WebApps using Pulumi… I want them to run dotnet, and tried that with the following code:
    const webapp = new web.WebApp(
    		projectKey,
    		{
    			reserved: true,
    			resourceGroupName: resourceGroup.name,
    			serverFarmId: appServicePlan.id,
    			siteConfig: {
    				linuxFxVersion: "DOTNET|6.0",
    				netFrameworkVersion: "v6.0",
    			},
    		}
    	);
    
    	new web.WebAppMetadata("meta", {
    		resourceGroupName: resourceGroup.name,
    		name: webapp.name,
    		properties: {
    			CURRENT_STACK: "dotnetcore",
    		},
    	});
    The
    linuxFxVersion
    kind of worked, which means that I can create a deployment in Azure’s Deployment Center that seems to recognize dotnet as runtime. However, if I then deploy a .net app, it seems to me as if the application is started like a PHP application, which obviously does not work… All I see is an apache forbidden page. I tried to add the
    WebAppMetadata
    with the
    CURRENT_STACK
    and the
    netFrameworkVersion
    , but that didn’t help neither, so I am wondering if that is necessary at all… Another thing is that the general settings tab within configuration in portal.azure.com has no stack selected, although I tried to configure it using the code above. Can anybody tell me what I am doing wrong?
    Ok, after hours of search I found that it is
    DOTNETCORE|6.0
    instead of
    DOTNET|6.0