https://pulumi.com logo
#kubernetes
Title
# kubernetes
b

brave-room-27374

01/25/2022, 3:38 AM
Hi, I am using
apple M1
and getting
403 HTTP error fetching plugin
while doing
pulumi up
, basically, I can't install kubernetes plugin
Copy code
😀 ➜  pulumi plugin install resource kubernetes v1.0.6
[resource plugin kubernetes-1.0.6] installing
error: [resource plugin kubernetes-1.0.6] downloading from : 403 HTTP error fetching plugin from <https://get.pulumi.com/releases/plugins/pulumi-resource-kubernetes-v1.0.6-darwin-arm64.tar.gz>
o

orange-policeman-59119

01/25/2022, 8:46 AM
Hey @brave-room-27374! It looks like that's a fairly old version of the provider, we probably don't have a darwin-arm64 build for it. Could you try this:
Copy code
pulumi plugin install resource kubernetes v3.14.1
Or follow the instructions here for installing the resource in your Pulumi project as a package dependency: https://www.pulumi.com/registry/packages/kubernetes/installation-configuration/#installation
If you could tell me where you got that version number, if it's in our docs or somewhere else, please let me know and I'll find out if we can update it!
m

miniature-musician-31262

01/25/2022, 4:27 PM
I checked, and the farthest back we go for this plugin on darwin-arm64 is
v2.8.3
.
b

brave-room-27374

01/26/2022, 3:59 AM
my
package.json
is
Copy code
"dependencies": {
    "@pulumi/kubernetes": "^3.14.1",
    "@pulumi/pulumi": "^3.22.1",
    "@rugal/pulumi-istio": "^1.0.6"
  },
so you can see I already made it the very latest version, but when I do
pulumi up
, it not only install
3.14.1
but also try to install
1.0.6
, which is very weird I wonder if it's because my mac is with
M1
chip, that brought the issue at the first place, unless if you guys can verify that pulumi is able to run on
M1
I just rerun it, able to reproduce it on my Mac. from log, pulumi downloaded the latest version but when comes to
up
it complains the
1.0.6
not found
o

orange-policeman-59119

01/26/2022, 4:03 AM
Is this project new or fairly old and you've just started working with it on your Mac? If it's new, would it be possible for you to email me your package.json & package-lock files or push this project to a git repo? My work email is friel@pulumi.com and I'm @AaronFriel on GitHub.
b

brave-room-27374

01/26/2022, 4:03 AM
hah, seems like it is because
.pulumi/plugin/xxx
is not in my
$PATH
that results into this error
💯
o

orange-policeman-59119

01/26/2022, 4:04 AM
Huh, that still sounds like a weird bug where it tries to use 1.0.6.
Glad you were able to figure out a fix, will look to see if there's a default we set somewhere that should be updated.
b

brave-room-27374

01/26/2022, 5:44 AM
ya, seems it's trying to use 1.0.6 as the fallback version, but not able to download it
s

sparse-park-68967

01/26/2022, 5:54 PM
Can you check if you have existing resources in the stack that use 1.0.6? Running a
pulumi stack export
and looking for things with
"type": "pulumi:providers:kubernetes"
should tell you
6 Views