getting a strange error when trying to import a Pi...
# aws
getting a strange error when trying to import a Pipeline via the ImportOptions path:
Copy code
* error reading CodePipeline: ValidationException: 1 validation error detected: Value at 'name' failed to satisfy constraint: Member must satisfy regular expression pattern: [A-Za-z0-9.@\-_]+
the pipeline does have "name" defined and it satisfies that regex
also doesn't seem to be nested, so it's not the name of an action or anything
i tried running it with verbose mode tuned all the way up and got nothing interesting
or at least, i couldn't find anything interesting personally
if i back up and try to just create the pipeline - i.e, not import it - it just works
so i'm wondering what it's pulling to validate
i grabbed the codebuild definition from AWS CLI and that name should statisfy the regex, and again, it doesn't look like action[0].name or anything so... seems like it's actually complaining about the codebuild name that AWS is giving it?
is it possible the regex being satisfied is not the one spit out?
yeah, not sure what's going on here, tried it on a different pipeline with a very simple name and i got the same error
the strange thing is this is happening only because of import; if i use the same definition, change the URN/name and deploy, it deploys
this might be a bug?
Sorry this took me so long to get to. Can you drop the code for the resource with the import statement (with confidential info redacted) in here so I can take a quick pass before passing you to the bug report link?
i also have the response from AWS CLI at the same time
just got the same error. different pipeline
where should i drop the bug report?
That's definitely odd. Head to, and can you drop me a link here so I can ensure it gets tagged for the triage team?