Hey! I'm checking out if the <typescript component...
# getting-started
Hey! I'm checking out if the typescript component package provider boilerplate to see if it will work for my use case of internally creating a reusable infrastructure component in my Organization. My issue is that I am not able to make the make commands
make install_provider
make generate
create nodejs sdk which defines the package in "@<my org>/<package name>". The package.json always builds the package name like this: "name": "@pulumi/xyz" Is this boilerplate and component package provider in general only for publishing packages to the public registry or is there something I'm missing?
@billowy-army-68599 thanks! This took one step further at least:) I'm struggling a bit with the build and test step
make install_nodejs_sdk
. It's returning this:
Copy code
> @easee/cp-pulumi-component-package-xyz@${VERSION} install
> node scripts/install-pulumi-plugin.js resource xyz ${VERSION}

[resource plugin xyz-0.0.1] installing
error: [resource plugin xyz-0.0.1] downloading from <https://github.com/easee/cp-pulumi-component-package-xyz/releases/download/v${VERSION}>: 404 HTTP error fetching plugin from <https://github.com/easee/cp-pulumi-component-package-xyz/releases/download/v0.0.1/pulumi-resource-xyz-v0.0.1-linux-amd64.tar.gz>

There was an error installing the resource provider plugin. You may try to manually installing the plugin by running `pulumi plugin install resource xyz 0.0.1`
Do I need to deploy an initial release to do local testing? this seems a bit strange
Just put the binary in your path
yes thanks. I've tried doing this with this command:
export PATH=$PATH:$PWD/bin
It might be because I instruct bash to be used as the shell in the makefile. The pushd command is not working if I run the make build commands without this
I usually do:
Copy code
export PATH=$PATH:$(pwd)/bin
like you, then use
yarn link @jaxxstorm/packagename
inside the examples directory
Thanks. I have switched the yarn commands to npm since we use this in my org. I can run "npm link" in the sdk/nodejs folder to make
npm link @easee/<packagename>
work in the examples directory, but this does not seem to be correct. The pulumi up command in the examples directory returns this:
Copy code
failed to discover plugin requirements: illegal semver returned by language host: easee/pulumi-aws-xyz@v${VERSION}: Invalid character(s) found in major number "${VERSION}"
Since the
make install_nodejs_sdk
fails I guess this is part of the reason the VERSION is not populated correctly. I've defined VERSION both in the schema and as an environment variable