https://pulumi.com logo
Title
p

prehistoric-london-9917

06/11/2022, 12:06 AM
Hi - I’m having an issue with an InlineProgram reporting this error:
error: Unhandled exception: Error: Detected multiple versions of '@pulumi/pulumi' in use in an inline automation api program.
I can’t sort out where it’s coming from because as near as I can tell, all the Pulumis are on the same version. I’ve looked for all
pulumi
directories in
node_modules
and got the version out of them.
$ find . -name "pulumi" -type d -exec cat {}/version.js \;
"use strict";
// Copyright 2016-2018, Pulumi Corporation.
//
// Licensed under the Apache License, Version 2.0 (the "License");
// you may not use this file except in compliance with the License.
// You may obtain a copy of the License at
//
//     <http://www.apache.org/licenses/LICENSE-2.0>
//
// Unless required by applicable law or agreed to in writing, software
// distributed under the License is distributed on an "AS IS" BASIS,
// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
// See the License for the specific language governing permissions and
// limitations under the License.
Object.defineProperty(exports, "__esModule", { value: true });
exports.version = "3.34.1";
//# sourceMappingURL=version.js.map"use strict";
// Copyright 2016-2018, Pulumi Corporation.
//
// Licensed under the Apache License, Version 2.0 (the "License");
// you may not use this file except in compliance with the License.
// You may obtain a copy of the License at
//
//     <http://www.apache.org/licenses/LICENSE-2.0>
//
// Unless required by applicable law or agreed to in writing, software
// distributed under the License is distributed on an "AS IS" BASIS,
// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
// See the License for the specific language governing permissions and
// limitations under the License.
Object.defineProperty(exports, "__esModule", { value: true });
exports.version = "3.34.1";
//# sourceMappingURL=version.js.map%
$ pulumi version
v3.34.1
yarn.lock
also seems to be resolving correctly:
"@pulumi/pulumi@^3.0.0":
  version "3.34.1"
  resolved "<https://registry.yarnpkg.com/@pulumi/pulumi/-/pulumi-3.34.1.tgz#55f040fe5e02d38837e90cb69481c500b8e879f7>"
  integrity sha512-Lnwc9aOnPuEL/2QWt6YYTkMO6VVWwrt+OO42AxQnhpiZkmGr2ujaIpX30U+7l1CctnszW+eKYknbjO7K+ZvIvg==
  dependencies:
    "@grpc/grpc-js" "~1.3.8"
The only reference to this error I can find is here: https://github.com/pulumi/pulumi/issues/7333 (and a link through to the original ticket that caused that check), but I didn’t get much help there. I’m not sure how to track this down since the stack trace isn’t giving me much else to go on.