Hi <#CRVK66N5U|azure>! I'm having issues authentic...
# azure
Hi #azure! I'm having issues authenticating using Workload Identity federation. I tried it out last week and everything worked great. When I run it now, I get a error 255
Copy code
Error: code: 255
      error: building auth config: Authenticating using the Azure CLI is only supported as a User (not a Service Principal).
      To authenticate to Azure using a Service Principal, you can use the separate 'Authenticate using a Service Principal'
      auth method - instructions for which can be found here: <https://www.pulumi.com/docs/intro/cloud-providers/azure/setup/#service-principal-authentication>
      Alternatively you can authenticate using the Azure CLI by using a User Account.
I ran this last week and everything worked. Now It's just impossible to get through. I noticed the pulumi cli got bumped a patch version since last week, but I tried to downgrade and that also did nothing. Does anyone have an idea what's going on?