10/27/2022, 9:20 AM
Hi folks, In the Kubernetes provider v3.22.0, server-side apply was made the default (see earlier). This exposed surprising errors, and caused problematic interactions with other tooling, such as Helm, that are not straight-forward to work around. Therefore, we’ve rolled back that change — server-side apply is back to being opt-in in v3.22.1. Update to that version of the Pulumi Kubernetes SDK using e.g.,
npm update @pulumi/kubernetes
. If you have set the flag
enableServerSideApply: false
in order to work around problems, the new release will respect that.


10/27/2022, 1:10 PM
Reading this, and the related documentation I think I figured out what caused the problems for me. We usually deploy from Jenkins, using Linux-based Pulumi container. But sometimes I also deploy from my laptop, which is a Windows 11 machine. The conflict is because Pulumi uses the name of the executable as the "manager". So it conflicts, because from Linux it's
manager: pulumi-resource-kubernetes
, but from Windows it's
manager: pulumi-resource-kubernetes.exe
. And since these are different, Pulumi thinks there is a conflict.
I've created a Github issue for this.