```kubernetes:core/v1:Namespace (1989f0db-a509-433...
# aws
Copy code
kubernetes:core/v1:Namespace (1989f0db-a509-433f-8223-2a463ead81c0):
    error: failed to initialize discovery client: exec plugin: invalid apiVersion "<http://client.authentication.k8s.io/v1alpha1|client.authentication.k8s.io/v1alpha1>"
@most-lighter-95902 please update to version. 0.40.0 of pulumi-eks
I’m on
"@pulumi/eks": "^0.41.0"
Still getting this error
Can you check your state for the provider versions and run ‘pulumi about’
What am I looking for?
Here’s the returned dependencies list:
Copy code
NAME                                  VERSION
@prisma/client                        3.14.0
@pulumi/aws                           5.9.1
@pulumi/awsx                          0.40.0
@pulumi/eks                           0.41.0
@pulumi/kubernetes                    3.19.4
@pulumi/kubernetes-cert-manager       0.0.3
@pulumi/pulumi                        3.35.1
@ronomon/crypto-async                 5.0.1
@sidetrek/pulumi-component-resources  0.2.62
@types/csurf                          1.11.2
@types/socket.io                      3.0.2
axios                                 0.24.0
cognito-express                       3.0.1
compression                           1.7.4
cookie-parser                         1.4.6
cors                                  2.8.5
dapr-client                           1.0.2
directory-tree                        3.3.0
dotenv                                10.0.0
download-git-repo                     3.0.2
express                               4.18.1
js-cookie                             3.0.1
query-string                          7.1.1
querystring                           0.2.1
ramda                                 0.27.2
react-cookie                          4.1.1
rollbar                               2.25.0
<http://socket.io|socket.io>                             4.5.1
temporalio                            0.23.2
uuid                                  8.3.2
winston                               3.7.2
@sidetrek/create-k8s-app              0.1.9
@types/cors                           2.8.12
@types/express                        4.17.13
@types/node                           16.11.38
concurrently                          7.2.1
jest                                  28.1.0
nodemon                               2.0.16
prisma                                3.14.0
tslint                                6.1.3
typescript                            4.7.3
@billowy-army-68599 any ideas? I’m seeing this error for all my pulumi k8s related commands
Could it be due to kubectl version mismatch?
Copy code
Client Version: <http://version.Info|version.Info>{Major:"1", Minor:"24", GitVersion:"v1.24.2", GitCommit:"f66044f4361b9f1f96f0053dd46cb7dce5e990a8", GitTreeState:"clean", BuildDate:"2022-06-15T14:14:10Z", GoVersion:"go1.18.3", Compiler:"gc", Platform:"darwin/amd64"}
Kustomize Version: v4.5.4
Server Version: <http://version.Info|version.Info>{Major:"1", Minor:"22+", GitVersion:"v1.22.9-eks-a64ea69", GitCommit:"540410f9a2e24b7a2a870ebfacb3212744b5f878", GitTreeState:"clean", BuildDate:"2022-05-12T19:15:31Z", GoVersion:"go1.16.15", Compiler:"gc", Platform:"linux/amd64"}
WARNING: version difference between client (1.24) and server (1.22) exceeds the supported minor version skew of +/-1
It’s strange because I’m able to access my cluster fine via kubectl
Unfortunately due to it being a weekend, I'm not able to answer quickly. The reason is because your Kubernetes provider might still have the wrong api version in. You need to check your stack state to see if it has an old provider version attached first. I won't be able to respond again this weekend
Oh oops - forgot that it’s the weekend. OK let me take a look at that
When I
pulumi up
my cluster again, it updated the kubeconfig so using
pulumi stack output
to use the updated kubeconfig solved the problem
Thanks and have a good weekend!