01/24/2023, 6:24 PM
I'm trying to create a custom provider using the pulumi-tf-provider-boilerplate for wrapping the ElasticStack terraform provider. I have gotten things building and can create an executable for the provider, and package for my language of choice (dotnet), however I'm having some issues getting Pulumi to pull the final plugin from GitHub releases, which should be possible based on comments here: Even with set, it doesn't seem like pulumi actually generates a URL in the shape GitHub supplies downloads in. (Next problem is that at least the dotnet provider seems to completely ignore that setting entirely, and still tries to pull from the general pulumi registry. I have tried specifying the ServerUrl option when marking the plugin for installation, but still no success). Is there some more documentation on how the releases/files in GitHub should be named for this to work? Link to the entire repo: (Appologies for the commit messages, I was quite frustrated)


01/24/2023, 6:48 PM
you need to speicify the plugindownload url like so:
so it would be
also: the plugin download url just pushes a binary which is a resource plugin
you’ll need to push your dotnet sdk to nuget separately
I don’t see any binaries in your github releases


01/24/2023, 6:49 PM
I'll try that url shape instead. The releases are just prereleases, but they should be available:
I will take a look at that repo, and try to follow it for getting everything working for this
I do have the nuget push done already:, so I'm aware of that part 🙂
Thanks for the help, got pulumi to download an execute the provider 🙂
Now however i got an issue with the provider seemingly not unwrapping secrets, and is trying to pass them along to terraform as maps, rather than strings. Is there something specific that needs to be done for that to work? The secrets are passed to a sub-object of the ProviderArgs, and not the root ProviderArgs, if that might make a difference?