03/23/2021, 8:53 PM
My second question: I created a config repo for my pulumi stacks (dev, stage, prod) each with their own stack specific config settings for GCP, etc. When I do a
pulumi new
and provide the path to the config I want to seed the project with it runs and then hits this permissions error.
stack name: (dev)
Created stack 'dev'

Creating virtual environment...
Finished creating virtual environment
Updating pip, setuptools, and wheel in virtual environment...
error: updating pip, setuptools, and wheel via '/Users/tyler/projects/propel-api/infrastructure/dev/venv/bin/python -m pip install --upgrade pip setuptools wheel': fork/exec /Users/tyler/projects/propel-api/infrastructure/dev/venv/bin/python: permission denied
trying to sort out this permissions issue now. If I run
pulumi new <path_to_repo>
that has the pulumi config that I want to seed this new repo with, I get the error above. If I run
pip install -r requirements.txt
from the new project it works. Then if I run
pulumi up
I get
error: failed to discover plugin requirements: fork/exec /Users/tyler/projects/propel-api/infrastructure/dev/venv/bin/python: permission denied
Figured it out, the config dir still had the venv from when I originally created the project, so that was coming across it seems when I seeded the new project with the config project!